Squirry - SPIP 1.92 - Site de tests Version php utilisée actuellement : 5.6.31 Squirry - SPIP 1.92 - Site de tests Version php utilisée actuellement : 5.6.31
spip192.jermer.fr
Accueil du site > Développements > jQuery ou Javascript dans Spip > Plugin jQdatePicker pour Spip 1.93
Version php utilisée actuellement : 5.6.31

Plugin jQdatePicker pour Spip 1.93

vendredi 28 décembre 2007


Ce plugin jQuery utilise le fichier jquery.datePicker.js Il nécessite le plugin jquery_plugins et le plugin CFG. Voir Lecture des informations contenues dans les fichiers plugin.xml Spip zone pour le téléchargement.

A terme, les fonctionnalités proposées par jquery_plugins devraient être utilisées. Actuellement, celui-ci permet de récupérer jquery.datePicker.js et de l’installer automatiquement dans le répertoire /lib à la racine du site.

Tous les fichiers js nécessaires sont chargés par le plugin.

Il suffit d’ajouter la class=“date-pick dp-applied” au(x) champ(s) du formulaire concerné.

La fonction datepicker a été portée sous jQuery par Kelvin Luck Son site est à visiter pour voir les différentes options. Je n’utilise qu’une d’entre elles. Les champs input ne sont pas pré-remplis. Il est possible de le faire (voir dans le plugin le fichier /js/datepicker.js).

Un modèle est disponible après activation du plugin, de jquery_plugins et de sa configuration avec config (sélectionner datepicker). Il suffit de placer <demojqdp|> dans un article.

Rappel : ne fonctionne correctement qu’avec Spip 1.93



Suivre la vie du site RSS 2.0 | Plan du site | Espace privé | SPIP

34 plugins actifs avec Spip 1.9.2o [19288]

En utilisant ce site, vous acceptez l’utilisation de cookies à des fins de personnalisation du contenu.


 
2007-12-28 01:58:29