Squirry - SPIP 1.92 - Site de tests Version php utilisée actuellement : 5.6.31 Squirry - SPIP 1.92 - Site de tests Version php utilisée actuellement : 5.6.31
spip192.jermer.fr
Accueil du site > Outils > Spip 1.9.20 et php (Version php utilisée actuellement : 5.6.31) dans le même (...)
Version php utilisée actuellement : 5.6.31

Spip 1.9.20 et php (Version php utilisée actuellement : 5.6.31) dans le même bateau

samedi 15 décembre 2012


L’hébergeur 1and1 vient d’annoncer le passage en mars prochain 2013) de ces serveurs sous la version 5.4.9 de php et l’arrêt des versions antérieures.(Version php utilisée actuellement : 5.6.31)

Cette annonce semble un peu radicale, alors que jusqu’à présent plusieurs versions semblaient coexister sans problème.

Après une semaine d’essais infructueux et des contacts avec le service technique au demeurant très réceptif, le passage à la version 5.4.9 ne semble plus poser problème aux versions de spip suivantes :

- spip 1.9.2o
- spip 2.1.19
- spip 3.0.5

Si vous voulez tester un site particulier chez 1and1 sous cette dernière version de php, vous pouvez l’activer à la demande en ajoutant le code suivant dans votre fichier .htaccess :


AddType x-mapp-php6 .php
AddHandler x-mapp-php6 .php

Version php utilisée actuellement : 5.6.31

Pour 1.9.2o il semble y avoir quelques effets de bord, quels warning dûs à des fonctions dépréciées dans d’anciens plugins.

exemple : ereg() devrait être remplacée par preg_match($pattern, $subject, $matches, PREG_OFFSET_CAPTURE, 3) ;

On peut aussi utiliser @ pour masquer quelques warning

exemple : if (@$statut[’statut’] == ’publie’)



Suivre la vie du site RSS 2.0 | Plan du site | Espace privé | SPIP

34 plugins actifs avec Spip 1.9.2o [19288]

En utilisant ce site, vous acceptez l’utilisation de cookies à des fins de personnalisation du contenu.


 
2012-12-15 18:46:12